Tuesday, October 7, 2008

VOIP Lab 7 – Final Configs

There are certainly a number of additional topics that could be covered under the topic of “VOIP Fundamentals”, such as basic gatekeeper functionality and IntServ (RSVP). However, rather than exploring these and other topics now, I have chosen to instead table these until we introduce further VOIP and UC technologies. For my next series of labs, I intend to introduce and explore Cisco Unified Communications Manager Express and Cisco Unity Express, using the same lab topology described in Lab 1.

Below are the final configurations for both the Baltimore, New York City, and “ISP” routers, with some edits and omissions for the sake of brevity. Note, my “ISP” router also doubles as an access server for my home lab, allowing reverse telnet to my router console ports.

Baltimore Router
version 12.4
service timestamps debug datetime msec localtime show-timezone year
service timestamps log datetime msec localtime show-timezone year
no service password-encryption
!
hostname Baltimore
!
!
card type t1 0 0
logging buffered 4096
!
no aaa new-model
clock timezone EST -5
clock summer-time EDT recurring
network-clock-participate wic 0
!
!
!
ip cef
!
!
no ip domain lookup
!
multilink bundle-name authenticated
!
isdn switch-type primary-ni
!
!
voice-card 0
dspfarm
dsp services dspfarm
!
!
username cisco privilege 15 password 0 cisco
archive
log config
hidekeys
!
!
controller T1 0/0/0
framing esf
linecode b8zs
cablelength short 133
pri-group timeslots 1-24
!
!
class-map match-all VOIP-TRAFFIC
match access-group name VOIP-PORTS
class-map match-all SECURE-WWW
match access-group name SSL
class-map match-all VOIP-SIGNALING
match access-group name VOIP-SETUP
!
!
policy-map VOIP-POLICY
class VOIP-TRAFFIC
priority 80
class VOIP-SIGNALING
bandwidth 8
class SECURE-WWW
bandwidth 150
class class-default
fair-queue
!
!
interface Loopback0
ip address 1.1.1.1 255.255.255.255
ip ospf network point-to-point
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface Service-Engine0/0
no ip address
shutdown
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0/0:23
no ip address
encapsulation hdlc
isdn switch-type primary-ni
isdn incoming-voice voice
no cdp enable
!
interface Serial0/2/0
bandwidth 1544
ip address 172.16.1.2 255.255.255.0
encapsulation ppp
service-policy output VOIP-POLICY
!
interface Serial0/2/1
no ip address
shutdown
clock rate 2000000
!
router ospf 1
router-id 1.1.1.1
log-adjacency-changes
network 1.1.1.1 0.0.0.0 area 1
network 172.16.1.0 0.0.0.255 area 0
!
!
ip http server
no ip http secure-server
!
ip access-list extended SSL
permit tcp any eq 443 any
permit tcp any any eq 443
ip access-list extended VOIP-PORTS
permit udp any any range 16384 32767
ip access-list extended VOIP-SETUP
permit tcp any eq 1720 any
permit tcp any any eq 1720
!
!
control-plane
!
!
voice-port 0/0/0:23
timeouts interdigit 3
description PRI ciruit to PSTN
!
voice-port 0/1/0
timeouts interdigit 3
connection plar opx 5001
description 410-555-5001
caller-id enable
!
voice-port 0/1/1
timeouts interdigit 3
connection plar opx 5002
description 410-555-5002
caller-id enable
!
voice-port 0/3/0
description Cal Ripken
station-id name Cal Ripken
station-id number 5001
caller-id enable
!
voice-port 0/3/1
cptone GR
description Nick Markakis
station-id name Nick Markakis
station-id number 5002
caller-id enable
!
!
dial-peer voice 5001 pots
destination-pattern 5001
port 0/3/0
!
dial-peer voice 5002 pots
destination-pattern 5002
port 0/3/1
!
dial-peer voice 6000 voip
description VOIP Peer to NYC
preference 1
max-conn 1
destination-pattern 600[12]
session target ipv4:172.16.2.2
codec g711ulaw
!
dial-peer voice 1 pots
description outbound via 410-555-5001
preference 2
destination-pattern 9T
port 0/1/0
!
dial-peer voice 2 pots
description outbound via 410-555-5002
preference 2
destination-pattern 9T
port 0/1/1
!
dial-peer voice 3 pots
description inbound PRI dial-peer
preference 1
incoming called-number 41055510..
direct-inward-dial
port 0/0/0:23
!
dial-peer voice 4 pots
description outbound PRI dial-peer
destination-pattern 9T
port 0/0/0:23
!
dial-peer voice 6001 pots
preference 2
destination-pattern 600[12]
port 0/0/0:23
forward-digits all
prefix 212555
!
dial-peer voice 6002 pots
preference 3
destination-pattern 600[12]
port 0/1/0
forward-digits all
prefix 212555
!
dial-peer voice 6003 pots
preference 3
destination-pattern 600[12]
port 0/1/1
forward-digits all
prefix 212555
!
!
gatekeeper
shutdown
!
!
line con 0
exec-timeout 0 0
password cisco
logging synchronous
login local
line aux 0
line 194
no activation-character
no exec
transport preferred none
transport input all
transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh
line vty 0 4
exec-timeout 0 0
password cisco
logging synchronous
login local
!
scheduler allocate 20000 1000
ntp clock-period 17179656
ntp server 7.7.7.7
!
webvpn cef
!
end



New York City Router
version 12.4
service timestamps debug datetime msec localtime show-timezone year
service timestamps log datetime msec localtime show-timezone year
no service password-encryption
!
hostname NewYork
!
!
card type t1 0 0
!
no aaa new-model
clock timezone EST -5
clock summer-time EST recurring
network-clock-participate wic 0
!
!
ip cef
!
!
no ip domain lookup
!
multilink bundle-name authenticated
!
isdn switch-type primary-ni
!
!
voice translation-rule 1
rule 1 /\(500[12]\)/ /410555\1/
!
voice translation-rule 2
rule 1 // /410555/
!
!
voice translation-profile prefix
translate called 1
!
!
voice-card 0
no dspfarm
!
!
username cisco privilege 15 password 0 cisco
archive
log config
hidekeys
!
!
controller T1 0/0/0
framing esf
linecode b8zs
cablelength short 133
pri-group timeslots 1-24
!
!
class-map match-all VOIP-TRAFFIC
match access-group name VOIP-PORTS
class-map match-all SECURE-WWW
match access-group name SSL
class-map match-all VOIP-SIGNALING
match access-group name VOIP-SETUP
!
!
policy-map VOIP-POLICY
class VOIP-TRAFFIC
priority 80
class VOIP-SIGNALING
bandwidth 8
class SECURE-WWW
bandwidth 150
class class-default
fair-queue
!
!
interface Loopback0
ip address 2.2.2.2 255.255.255.255
ip ospf network point-to-point
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0/0:23
no ip address
encapsulation hdlc
isdn switch-type primary-ni
isdn incoming-voice voice
no cdp enable
!
interface Serial0/2/0
description Link to Baltimore via Hub (R7)
bandwidth 1544
ip address 172.16.2.2 255.255.255.0
encapsulation ppp
service-policy output VOIP-POLICY
!
interface Serial0/2/1
no ip address
shutdown
!
router ospf 1
router-id 2.2.2.2
log-adjacency-changes
network 2.2.2.2 0.0.0.0 area 2
network 172.16.2.0 0.0.0.255 area 0
!
!
ip http server
no ip http secure-server
!
ip access-list extended SSL
permit tcp any eq 443 any
permit tcp any any eq 443
ip access-list extended VOIP-PORTS
permit udp any any range 16384 32767
ip access-list extended VOIP-SETUP
permit tcp any eq 1720 any
permit tcp any any eq 1720
!
!
voice-port 0/0/0:23
description PRI to PSTN
!
voice-port 0/1/0
connection plar opx 6001
description 212-555-6001
caller-id enable
!
voice-port 0/1/1
connection plar opx 6002
description 212-555-6002
caller-id enable
!
voice-port 0/3/0
ring cadence pattern04
description Tom Seaver
station-id name Tom Seaver
station-id number 6001
caller-id enable
!
voice-port 0/3/1
description David Wright
station-id name David Wright
station-id number 6002
caller-id enable
!
!
dial-peer voice 6001 pots
destination-pattern 6001
port 0/3/0
!
dial-peer voice 6002 pots
destination-pattern 6002
port 0/3/1
!
dial-peer voice 5000 voip
description VOIP Peer to Baltimore
preference 1
max-conn 1
destination-pattern 500[12]
session target ipv4:172.16.1.2
codec g711ulaw
!
dial-peer voice 1 pots
description outbound via 212-555-6001
preference 2
destination-pattern 9[2-9].........
port 0/1/0
!
dial-peer voice 2 pots
description outbound via 212-555-6002
preference 2
destination-pattern 9[2-9].........
port 0/1/1
!
dial-peer voice 3 pots
description Inbound Dial-Peer via PRI
incoming called-number 21255520..
direct-inward-dial
port 0/0/0:23
!
dial-peer voice 4 pots
description Outbound Dial-Peer via PRI
preference 1
destination-pattern 9[2-9].........
port 0/0/0:23
!
dial-peer voice 5001 pots
translation-profile outgoing prefix
preference 2
destination-pattern 500[12]
port 0/0/0:23
forward-digits all
!
dial-peer voice 5002 pots
translation-profile outgoing prefix
preference 3
destination-pattern 500[12]
port 0/1/0
forward-digits all
!
dial-peer voice 5003 pots
translation-profile outgoing prefix
preference 3
destination-pattern 500[12]
port 0/1/1
forward-digits all
!
!
gatekeeper
shutdown
!
!
line con 0
exec-timeout 0 0
logging synchronous
login local
line aux 0
line vty 0 4
exec-timeout 0 0
logging synchronous
login local
!
scheduler allocate 20000 1000
ntp clock-period 17179816
ntp server 7.7.7.7
!
webvpn cef
!
end

ISP Router
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname ISP
!
!
logging message-counter syslog
no logging buffered
!
no aaa new-model
clock timezone EST -5
clock summer-time EDT recurring
!
dot11 syslog
ip source-route
!
!
ip cef
!
!
no ip domain lookup
ip host r1 2066 10.1.1.3
ip host r2 2067 10.1.1.3
ip host r3 2068 10.1.1.3
ip host r4 2069 10.1.1.3
ip host r5 2070 10.1.1.3
ip host r6 2071 10.1.1.3
ip host s1 2072 10.1.1.3
no ipv6 cef
!
multilink bundle-name authenticated
!
!
voice-card 0
no dspfarm
!
!
!
!
!
username cisco privilege 15 password 0 cisco
archive
log config
hidekeys
!
!
interface Loopback0
ip address 7.7.7.7 255.255.255.255
ip ospf network point-to-point
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 10.1.1.3 255.255.255.0
duplex auto
speed auto
no keepalive
!
interface Serial0/0/0
description Link to Baltimore
bandwidth 128
ip address 172.16.1.1 255.255.255.0
encapsulation ppp
clock rate 128000
!
interface Serial0/0/1
description Link to New York
bandwidth 128
ip address 172.16.2.1 255.255.255.0
encapsulation ppp
clock rate 128000
!
interface Serial0/1/0
no ip address
shutdown
clock rate 2000000
!
interface Serial0/1/1
no ip address
shutdown
clock rate 2000000
!
interface Serial0/2/0
no ip address
shutdown
clock rate 2000000
!
interface Serial0/2/1
no ip address
shutdown
clock rate 2000000
!
router ospf 1
router-id 7.7.7.7
log-adjacency-changes
passive-interface default
no passive-interface Serial0/0/0
no passive-interface Serial0/0/1
network 7.7.7.7 0.0.0.0 area 0
network 172.16.1.0 0.0.0.255 area 0
network 172.16.2.0 0.0.0.255 area 0
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 10.1.1.1
ip http server
no ip http secure-server
!
!
gatekeeper
shutdown
!
!
line con 0
exec-timeout 20 0
logging synchronous
login local
line aux 0
line 1/0 1/15
no exec
transport input all
line vty 0 4
exec-timeout 20 0
logging synchronous
login local
!
scheduler allocate 20000 1000
ntp master 3
ntp server 198.82.1.201
end

ISP#

No comments: