Wednesday, October 1, 2008

VOIP Lab 6 – Local Call Admission Control & QoS

Fuzzy Dunlop did express a couple of concerns with the VOIP pilot. First, the organization is concerned about voice quality and it also has a critical secure web-based CRM tool. Secondly, Fuzzy Dunlop want to make sure that if the WAN link fails, internal calls can still be routed out the PTSN.

Tasks 6.1 – Local Call Admission Control & QoS Configuration
The following tasks are required for this lab:

1. Configure each voice gateway to route internal four-digit dial calls out the PSTN in the event of a WAN failure. Make sure the IP path is preferred first; the PRI circuit second; the POTS lines third.

2. You may not use any sort of digit translation on the Baltimore router to achieve task #1.

3. You must use digit translation on the NY router to achieve task #2.

4. Limit the WAN links to one call using a Local CAC mechanism.

5. Configure a QOS policy that gives voice traffic a strict priority for one call, provides call set-up with 8k of bandwidth, secure www with 150k of bandwidth, and everything else in a default class.

6. Verify calling, including routing calls to the PSTN during a WAN failure.

Tasks 6.2 – Local Call Admission Control & QoS Verification

1. In order to configure call routing of the four-digit dial calls via the PSTN, three additional POTS dial-peers need to be added to each router; one pointing to the PRI and the other two pointing to the two POTS connections. Additionally, preference values need to be added to these dial-peers, as well as the VOIP dial peers.

2. To meet configuration task #2 above, digits need to be prefixed under each of three new POTS dial-peers on the Baltimore router. Below is configuration additions and changes made to Baltimore.

Baltimore#sh run begin dial-peer voice 6000
dial-peer voice 6000 voip
description VOIP Peer to NYC
preference 1
max-conn 1
destination-pattern 600[12]
session target ipv4:172.16.2.2
codec g711ulaw
!
!
dial-peer voice 6001 pots
preference 2
destination-pattern 600[12]
port 0/0/0:23
forward-digits all
prefix 212555

!
dial-peer voice 6002 pots
preference 3
destination-pattern 600[12]
port 0/1/0
forward-digits all
prefix 212555

!
dial-peer voice 6003 pots
preference 3
destination-pattern 600[12]
port 0/1/1
forward-digits all
prefix 212555

!

3. For New York City, a voice-translation rule and voice translation pattern are created and then associated with each of the three new POTS dial-peers. Interestingly, there are a couple of ways to configure the voice-translation rule. The configuration below shows two viable options, although voice-translation rule 1 is the one being applied, which is the more specific rule for numbers 5001 and 5002.

You can also test the rule by issueing the test voice translation-rule [rule number] [phone number]
!
voice translation-rule 1
rule 1 /\(500[12]\)/ /410555\1/
!
voice translation-rule 2
rule 1 // /410555/
!
!
voice translation-profile prefix
translate called 1
!
!
!
dial-peer voice 5000 voip
description VOIP Peer to Baltimore
preference 1
max-conn 1
destination-pattern 500[12]
session target ipv4:172.16.1.2
codec g711ulaw
!
dial-peer voice 5001 pots
translation-profile outgoing prefix
preference 2

destination-pattern 500[12]
port 0/0/0:23
forward-digits all
!
dial-peer voice 5002 pots
translation-profile outgoing prefix
preference 3
destination-pattern 500[12]
port 0/1/0
forward-digits all
!
dial-peer voice 5003 pots
translation-profile outgoing prefix
preference 3

destination-pattern 500[12]
port 0/1/1
forward-digits all
!

NewYork#test voice translation-rule 1 5001
Matched with rule 1
Original number: 5001 Translated number: 4105555001
Original number type: none Translated number type: none
Original number plan: none Translated number plan: none

NewYork#test voice translation-rule 2 5001
Matched with rule 1
Original number: 5001 Translated number: 4105555001
Original number type: none Translated number type: none
Original number plan: none Translated number plan: none

4. A Low Latency Queuing (LLQ) policy is created and applied to the serial interface. The policy is identical on both ends.

!
ip access-list extended SSL
permit tcp any eq 443 any
permit tcp any any eq 443
ip access-list extended VOIP-PORTS
permit udp any any range 16384 32767
ip access-list extended VOIP-SETUP
permit tcp any eq 1720 any
permit tcp any any eq 1720
!
!
class-map match-all VOIP-TRAFFIC
match access-group name VOIP-PORTS
class-map match-all SECURE-WWW
match access-group name SSL
class-map match-all VOIP-SIGNALING
match access-group name VOIP-SETUP
!
!
policy-map VOIP-POLICY
class VOIP-TRAFFIC
priority 80
class VOIP-SIGNALING
bandwidth 8
class SECURE-WWW
bandwidth 150
class class-default
fair-queue
!
interface Serial0/2/0
service-policy output VOIP-POLICY



5. Finally, we verify the configuration by placing two phone calls. The first call is placed from Cal Ripken (ext. 5001) to Tom Seaver (ext. 6001). We know it is going across the WAN, because CallID 0xC5 verifies the Dial Peers.

A second call is placed from Nick Markakis (ext. 5002) to David Wright (ext. 6002.). Based on the output below, the router indicates the maximum number of connections on dial-peer 6000 as been reached, and the call is now being placed out the PRI as number 2125556002. CallID 0xC8 also verifies that the call is using dial-peer 6001, which is associated with the PRI.

Baltimore#
.Sep 30 2008 17:33:26.002 EDT: %CALL_CONTROL-6-MAX_CONNECTIONS: Maximum number of connections reached for dial-peer 6000

Baltimore#
.Sep 30 2008 17:33:32.286 EDT: %ISDN-6-CONNECT: Interface Serial0/0/0:22 is now connected to 2125556002 N/A

Baltimore#sh voice call stat
CallID CID ccVdb Port DSP/Ch Called # Codec Dial-peers
0xC5 13E2 0x486A7568 0/3/0 0/2:1 6001 g711ulaw 5001/6000
0xC7 13E7 0x47EB06D8 0/3/1 No DSP 6002 None 5002/6001
0xC8 13E7 0x48C50408 0/0/0:23.23 No DSP *6002 None 6001/5002
2 active calls found


Lab references:
Cisco Systems. Number Translation using Voice Translation Profiles.

Cisco Systems. VoIP over PPP Links with Quality of Service (LLQ / IP RTP Priority, LFI, cRTP).

Davidson, Jonathan, Kevin (2002). Deploying Cisco Voice over IP Solutions (Chapter 4). Indianapolis: Cisco Press.

No comments: