Monday, December 22, 2008

CUCME-CUE Lab 1 – Initial Configuration

CUCME-CUE Lab 1 Prerequisites
Prior to beginning the basic IP Setup for this series of CUCME-CUE labs, configure the Adtran Atlas 550 to support the simulated PSTN dial plan depicted in diagram in CUCME-CUE Labs – Background. Please refer to VOIP Fundamentals Lab 1 - PSTN Setup on how to configure the Adtran for the dial plan depicted in CUCME-CUE Scenario Background.

The CUCME-CUE labs also assume that you have the appropriate IOS files, CUCME files, and CUE files. These labs also assume that you have valid CCO access and licenses for any files that you may be downloading and installing on your lab equipment.

These labs will be based on CME 7.0(1) and IOS 12.4(22)T. If you need to upgrade the IOS refer to the Cisco Unified CME and Cisco IOS Software Version Compatibility Matrix. For now, my recommendation is not to install the CME files. I will cover that in a subsequent lab.

Tasks Lab 1.1 – Initial IP Network Setup
1. Configure the IP addressing based on the diagram in VoIP Lab 1.
2. Configure R7 to serve as the frame relay switch for WAN. Set the clocking to 512000.
3. Make sure you have an “external” NTP clocking source for your LAB. (Note, depending on your own lab, this may vary. I will discuss my configuration below.)
4. Configure the Frame Relay connection on both Baltimore and New York as a point-to-point interface.
5. Provide a loopback interface on each router.
6. Configure your LAN networks as depicted the CUCME-CUE Labs – Background posting.
7. On the Baltimore Router, the connection between the router and Ethernet Switch Module must be over a Layer 2 trunk.
8. Configure IP Services on each router to support IP Phones. Reserve the first 16-block of addresses accordingly.
9. Configure the LAN ports so that Phones receive their appropriate IP information and any PCs on those LAN ports receive their appropriate IP information.
10. Configure OSPF routing for the network. The WAN/Frame Cloud should use Area 0; Baltimore Area 1; New York Area 2.
11. The loopbacks should be placed into each area accordingly; these routes should be depicted in the route tables as /24 networks.
12. The “Out of Band” network, not part of the LAB should not be added to OSPF.
13. Test connectivity. Verify by ping devices on New York from Baltimore, and vice-versa.


Tasks Lab 1.2 – Verifying IP Network Setup
1. Below is a snippet of router config on R7, which shows the configuration of the router as a Frame Relay switch. I have also configured the router to act as an NTP Server as well as an Access Server for my lab.

!
hostname ISP
!
ip host r1 2066 10.1.1.4
ip host r2 2067 10.1.1.4
ip host r3 2068 10.1.1.4
ip host r4 2069 10.1.1.4
ip host r5 2070 10.1.1.4
ip host r6 2071 10.1.1.4
ip host s1 2072 10.1.1.4
!
frame-relay switching
!
!
interface FastEthernet0/0
ip address 10.1.1.4 255.255.255.0
duplex auto
speed auto
ntp broadcast
!
!
interface Serial0/0/0
description frame-relay link to Baltimore
no ip address
encapsulation frame-relay
no fair-queue
clock rate 512000
frame-relay lmi-type cisco
frame-relay intf-type dce
frame-relay route 102 interface Serial0/0/1 201
!
interface Serial0/0/1
description frame-relay to New York
no ip address
encapsulation frame-relay
clock rate 512000
frame-relay lmi-type cisco
frame-relay intf-type dce
frame-relay route 201 interface Serial0/0/0 102
!
line 1/0 1/15
no exec
transport input all
!
ntp master



2. Below are the configurations for the Frame Relay connectivity on both Baltimore and New York.

Baltimore#
!
interface Serial0/2/0
no ip address
encapsulation frame-relay
no fair-queue
frame-relay lmi-type cisco
!
interface Serial0/2/0.102 point-to-point
bandwidth 1544
ip address 172.16.1.1 255.255.255.252
ip ospf network point-to-point
snmp trap link-status
frame-relay interface-dlci 102
!


NewYork#
!
interface Serial0/2/0
no ip address
encapsulation frame-relay
no fair-queue
frame-relay lmi-type cisco
!
interface Serial0/2/0.201 point-to-point
bandwidth 1544
ip address 172.16.1.2 255.255.255.252
ip ospf network point-to-point
snmp trap link-status
frame-relay interface-dlci 201
!

Baltimore#ping 172.16.1.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.1.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/8/8 ms

NewYork#ping 172.16.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/8/8 ms



3. Configuring the EtherSwitch Service Module (NME-16ES-1G-P), as described in Task 1.1.7, presents a unique challenge. ES modules have their own processors, switching engines, software and flash memory that run independent of the host router resources. “EtherSwitch Service Module (ES) Configuration Example” is a good reference document.

The trick, or “gotchya” described above in Task 1.1.7 is to require a Layer 2 link between the router and the EtherSwitch Service Module. This requires the use of dot1q sub-interfaces on the router’s interface GigabitEthernet1/0. However, as I found, you cannot use a dot1q sub-interfaces to “session” into EtherSwitch Service Module.

For example:

!
interface GigabitEthernet1/0
no ip address
!
interface GigabitEthernet1/0.10
description Management Vlan
encapsulation dot1Q 10
ip address 10.1.10.1 255.255.255.0
!

Baltimore#service-module gigabitEthernet 1/0.10 session
^
% Invalid input detected at '^' marker.

Baltimore#service-module gigabitEthernet 1/0 session
IP address needs to be configured on interface GigabitEthernet1/0
Baltimore#


So, the trick is to first configure the interface GigabitEthernet1/0 on the router as a traditional Layer-3 routed interface, which allows you to session into the EtherSwitch Service Module.

Baltimore#
interface GigabitEthernet1/0
ip address 10.1.10.1 255.255.255.0
!
Baltimore#service-module gigabitEthernet 1/0 session
Trying 10.1.10.1, 2066 ... Open
Switch>

The next step, once you have connectivity to the EtherSwitch Service Module, is to configure the VLANs and trunk back to the router. Another important step will be to enabling telnet (or SSH) on the switch to allow access. Failure to assign a password to the VTY ports could impede your access to the EtherSwitch Service Module.

hostname Baltimore-S1
!
!
username cisco123 privilege 15 password 0 *****
!
vlan 10
name MNGMT-BMORE
!
vlan 11
name DATA-BMORE
!
vlan 12
name VOICE-BMORE
!
!
interface GigabitEthernet1/0/2
switchport trunk encapsulation dot1q
switchport trunk native vlan 11
switchport trunk allowed vlan 10-12
switchport mode trunk
!
interface Vlan1
no ip address
!
interface Vlan10
description Management Vlan
ip address 10.1.10.2 255.255.255.0
!
interface Vlan11
description Data Vlan
ip address 10.1.11.2 255.255.255.0
!
interface Vlan12
description Voice Vlan
ip address 10.1.12.2 255.255.255.0
!
ip default-gateway 10.1.10.1
ip classless
ip route 0.0.0.0 0.0.0.0 10.1.10.1
!line vty 0 4
exec-timeout 5 0
logging synchronous
login local

The final step is to remove the IP address from the interface GigabitEthernet1/0 on the router and add the appropriate dot1q sub-interfaces.

!
interface GigabitEthernet1/0
no ip address
!
interface GigabitEthernet1/0.10
description Management Vlan
encapsulation dot1Q 10
ip address 10.1.10.1 255.255.255.0
!
interface GigabitEthernet1/0.11
description Data Vlan
encapsulation dot1Q 11 native
ip address 10.1.11.1 255.255.255.0
!
interface GigabitEthernet1/0.12
description Voice Vlan
encapsulation dot1Q 12
ip address 10.1.12.1 255.255.255.0


Under the configuration abve, will only be able to telnet (or SSH) into the EtherSwitch Service Module; you will be unable to “session” into module, which presents a potential management risk. However, based on my prior CCIE lab experience, sometimes the questions do not accurately reflect “real world” configurations.

Baltimore#service-module gigabitEthernet 1/0 session
IP address needs to be configured on interface GigabitEthernet1/0
Baltimore#telnet 10.1.10.2
Trying 10.1.10.2 ... Open

User Access Verification

Username: cisco123
Password:
Baltimore-S1#



4. The configuration of the switch ports for the IP Phones is rather straight forward. Below is the output from the EtherSwitch Service Module (Baltimore):

Baltimore-S1(config)#interface range fastEthernet 1/0/1 – 3
Baltimore-S1(config-if-range)# switchport trunk encapsulation dot1q
Baltimore-S1(config-if-range)# switchport trunk native vlan 11
Baltimore-S1(config-if-range)# switchport mode trunk
Baltimore-S1(config-if-range)# switchport voice vlan 12
Baltimore-S1(config-if-range)# spanning-tree portfast



5. The IP Phones required a DHCP server to obtain their IP Addressing, Default Route, and CUCME information. Below is the configuration from New York; note the exclusion of address .1 - .15.

ip dhcp excluded-address 10.1.21.1 10.1.21.15
ip dhcp excluded-address 10.1.22.1 10.1.22.15
!
ip dhcp pool VOICE
network 10.1.22.0 255.255.255.0
option 150 ip 10.1.22.1
dns-server 4.2.2.1 4.2.2.2
default-router 10.1.22.1
domain-name ballplayersllc.com
!
ip dhcp pool DATA
network 10.1.21.0 255.255.255.0
default-router 10.1.21.1
dns-server 4.2.2.1 4.2.2.2
domain-name ballplayersllc.com
!



6. There is a fairly quick way to verify that both the IP Phones on each router are receiving their proper IP Addresses as well as confirming end-to-end IP connectivity. On each router, a “show ip dhcp binding” provides the IP addresses the phones received from DHCP. Then, from one router, ping the IP Phones on the other router. For example:

NewYork#sh ip dhcp binding
Bindings from all pools not associated with VRF:
IP address Client-ID/ Lease expiration Type
Hardware address/
User name
10.1.22.17 0100.21d8.b9bc.72 Dec 23 2008 11:44 AM Automatic
10.1.22.19 0100.21d8.ba23.73 Dec 23 2008 11:44 AM Automatic
NewYork#

Baltimore#sh ip dhcp binding
Bindings from all pools not associated with VRF:
IP address Client-ID/ Lease expiration Type
Hardware address/
User name
10.1.12.16 0100.21d8.ba23.a1 Dec 23 2008 11:44 AM Automatic
10.1.12.18 0100.2333.1aed.cc Dec 23 2008 11:46 AM Automatic
10.1.12.20 0100.1fca.e92c.ce Dec 23 2008 11:42 AM Automatic
Baltimore#
Baltimore#ping 10.1.22.17

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.22.17, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/8/8 ms
Baltimore#ping 10.1.22.19

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.22.19, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/8/8 ms
Baltimore#

NewYork#ping 10.1.12.16

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.12.16, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/8/12 ms
NewYork#ping 10.1.12.18

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.12.18, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/8/12 ms
NewYork#ping 10.1.12.20

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.12.20, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/8/8 ms
NewYork#



7. Finally, we’ll verify the route tables on each router.

NewYork#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is 10.1.1.1 to network 0.0.0.0

1.0.0.0/24 is subnetted, 1 subnets
O IA 1.1.1.0 [110/65] via 172.16.1.1, 00:07:32, Serial0/2/0.201
2.0.0.0/24 is subnetted, 1 subnets
C 2.2.2.0 is directly connected, Loopback0
172.16.0.0/30 is subnetted, 1 subnets
C 172.16.1.0 is directly connected, Serial0/2/0.201
10.0.0.0/24 is subnetted, 7 subnets
O IA 10.1.11.0 [110/65] via 172.16.1.1, 00:07:32, Serial0/2/0.201
O IA 10.1.10.0 [110/65] via 172.16.1.1, 00:07:32, Serial0/2/0.201
O IA 10.1.12.0 [110/65] via 172.16.1.1, 00:07:33, Serial0/2/0.201
C 10.1.1.0 is directly connected, FastEthernet0/0.1
C 10.1.22.0 is directly connected, FastEthernet0/0.22
C 10.1.21.0 is directly connected, FastEthernet0/0.21
C 10.1.20.0 is directly connected, FastEthernet0/0.20
S* 0.0.0.0/0 [1/0] via 10.1.1.1
NewYork#


Baltimore#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is 10.1.1.1 to network 0.0.0.0

1.0.0.0/24 is subnetted, 1 subnets
C 1.1.1.0 is directly connected, Loopback0
2.0.0.0/24 is subnetted, 1 subnets
O IA 2.2.2.0 [110/65] via 172.16.1.2, 00:07:51, Serial0/2/0.102
172.16.0.0/30 is subnetted, 1 subnets
C 172.16.1.0 is directly connected, Serial0/2/0.102
10.0.0.0/24 is subnetted, 7 subnets
C 10.1.11.0 is directly connected, GigabitEthernet1/0.11
C 10.1.10.0 is directly connected, GigabitEthernet1/0.10
C 10.1.12.0 is directly connected, GigabitEthernet1/0.12
C 10.1.1.0 is directly connected, FastEthernet0/0
O IA 10.1.22.0 [110/65] via 172.16.1.2, 00:07:52, Serial0/2/0.102
O IA 10.1.21.0 [110/65] via 172.16.1.2, 00:07:52, Serial0/2/0.102
O IA 10.1.20.0 [110/65] via 172.16.1.2, 00:07:53, Serial0/2/0.102
S* 0.0.0.0/0 [1/0] via 10.1.1.1
Baltimore#



8. Below are snippets from router and switch configurations for Baltimore & New York. For brevity, I have omitted parts.

Baltimore Router:
Baltimore#sh run
Building configuration...
!
!
hostname Baltimore
!
ip dhcp excluded-address 10.1.11.1 10.1.11.15
ip dhcp excluded-address 10.1.12.1 10.1.12.15
!
ip dhcp pool VOICE
network 10.1.12.0 255.255.255.0
default-router 10.1.12.1
option 150 ip 10.1.12.1
dns-server 4.2.2.1 4.2.2.2
domain-name ballplayerllc.com
!
ip dhcp pool DATA
network 10.1.11.0 255.255.255.0
default-router 10.1.11.1
dns-server 4.2.2.1 4.2.2.2
domain-name ballplayerllc.com
!
!
ip domain name ballplayerllc.com
!
!
interface Loopback0
ip address 1.1.1.1 255.255.255.0
ip ospf network point-to-point
!
interface FastEthernet0/0
ip address 10.1.1.101 255.255.255.0
description "Out of Band Management - Not Part of Lab!"
duplex auto
speed auto
!
interface Service-Engine0/0
no ip address
shutdown
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/2/0
no ip address
encapsulation frame-relay
no fair-queue
frame-relay lmi-type cisco
!
interface Serial0/2/0.102 point-to-point
bandwidth 1544
ip address 172.16.1.1 255.255.255.252
ip ospf network point-to-point
snmp trap link-status
frame-relay interface-dlci 102
!
interface Serial0/2/1
no ip address
shutdown
clock rate 2000000
!
interface GigabitEthernet1/0
no ip address
!
interface GigabitEthernet1/0.10
description MNGMT-BMORE
encapsulation dot1Q 10
ip address 10.1.10.1 255.255.255.0
!
interface GigabitEthernet1/0.11
description DATA-BMORE
encapsulation dot1Q 11 native
ip address 10.1.11.1 255.255.255.0
!
interface GigabitEthernet1/0.12
description VOICE-BMORE
encapsulation dot1Q 12
ip address 10.1.12.1 255.255.255.0
!
router ospf 1
router-id 1.1.1.1
log-adjacency-changes
passive-interface default
no passive-interface Serial0/2/0.102
network 1.1.1.0 0.0.0.255 area 1
network 10.1.10.0 0.0.0.255 area 1
network 10.1.11.0 0.0.0.255 area 1
network 10.1.12.0 0.0.0.255 area 1
network 172.16.1.0 0.0.0.3 area 0
!
!
line con 0
exec-timeout 0 0
logging synchronous
login local
line aux 0
line 66
no activation-character
no exec
transport preferred none
transport input all
transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh
line 194
no activation-character
no exec
transport preferred none
transport input all
transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh
line vty 0 4
exec-timeout 0 0
logging synchronous
login local
!
scheduler allocate 20000 1000
ntp server 10.1.1.4
end


Baltimore EtherSwitch Service Module:
Baltimore-S1#sh run
Building configuration...
!
hostname Baltimore-S1
!
!
vlan 10
name MNGMT-BMORE
!
vlan 11
name DATA-BMORE
!
vlan 12
name VOICE-BMORE
!
interface FastEthernet1/0/1
description 7962 MAC 001FCAE92CCE
switchport trunk encapsulation dot1q
switchport trunk native vlan 11
switchport mode trunk
switchport voice vlan 12
spanning-tree portfast
!
interface FastEthernet1/0/2
description 7942 MAC 0021D8BA23A1
switchport trunk encapsulation dot1q
switchport trunk native vlan 11
switchport mode trunk
switchport voice vlan 12
spanning-tree portfast
!
interface FastEthernet1/0/3
description 7942 MAC 0023331AEDCC
switchport trunk encapsulation dot1q
switchport trunk native vlan 11
switchport mode trunk
switchport voice vlan 12
spanning-tree portfast
!
interface FastEthernet1/0/4
!
!output omitted!
!
interface GigabitEthernet1/0/2
switchport trunk encapsulation dot1q
switchport trunk native vlan 11
switchport trunk allowed vlan 10-12
switchport mode trunk
!
interface Vlan1
no ip address
!
interface Vlan10
description Management Vlan
ip address 10.1.10.2 255.255.255.0
!
interface Vlan11
description Data Vlan
ip address 10.1.11.2 255.255.255.0
!
interface Vlan12
description Voice Vlan
ip address 10.1.12.2 255.255.255.0
!
ip default-gateway 10.1.10.1
ip classless
ip route 0.0.0.0 0.0.0.0 10.1.10.1
ip http server
!
!
line con 0
exec-timeout 5 0
logging synchronous
login local
line vty 0 4
exec-timeout 5 0
logging synchronous
login local
line vty 5 15
exec-timeout 5 0
logging synchronous
login local
!
end


New York Router:
NewYork#sh run
Building configuration...
!
hostname NewYork
!
!
ip cef
ip dhcp excluded-address 10.1.21.1 10.1.21.15
ip dhcp excluded-address 10.1.22.1 10.1.22.15
!
ip dhcp pool VOICE
network 10.1.22.0 255.255.255.0
option 150 ip 10.1.22.1
dns-server 4.2.2.1 4.2.2.2
default-router 10.1.22.1
domain-name ballplayersllc.com
!
ip dhcp pool DATA
network 10.1.21.0 255.255.255.0
default-router 10.1.21.1
dns-server 4.2.2.1 4.2.2.2
domain-name ballplayersllc.com
!
!
no ip domain lookup
ip domain name ballplayersllc.com
!
interface Loopback0
ip address 2.2.2.2 255.255.255.0
ip ospf network point-to-point
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.1
description "Out of Band Management - Not Part of Lab!"
encapsulation dot1Q 1
ip address 10.1.1.102 255.255.255.0
!
interface FastEthernet0/0.20
description NEWYORK-MANAGEMENT-VLAN
encapsulation dot1Q 20
ip address 10.1.20.1 255.255.255.0
!
interface FastEthernet0/0.21
description NEWYORK-DATA-VLAN
encapsulation dot1Q 21 native
ip address 10.1.21.1 255.255.255.0
!
interface FastEthernet0/0.22
description NEWYORK-VOICE-VLAN
encapsulation dot1Q 22
ip address 10.1.22.1 255.255.255.0
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/2/0
no ip address
encapsulation frame-relay
frame-relay lmi-type cisco
!
interface Serial0/2/0.201 point-to-point
bandwidth 1544
ip address 172.16.1.2 255.255.255.252
ip ospf network point-to-point
snmp trap link-status
frame-relay interface-dlci 201
!
interface Serial0/2/1
no ip address
shutdown
clock rate 2000000
!
router ospf 1
router-id 2.2.2.2
log-adjacency-changes
passive-interface default
no passive-interface Serial0/2/0.201
network 2.2.2.0 0.0.0.255 area 2
network 10.1.20.0 0.0.0.255 area 2
network 10.1.21.0 0.0.0.255 area 2
network 10.1.22.0 0.0.0.255 area 2
network 172.16.1.0 0.0.0.3 area 0
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 10.1.1.1
no ip http server
no ip http secure-server
!
line con 0
exec-timeout 15 0
logging synchronous
login local
line aux 0
line vty 0 4
exec-timeout 15 0
logging synchronous
login local
length 0
!
scheduler allocate 20000 1000
ntp server 10.1.1.4
end


New York Switch:
!
hostname NewYork-S1
!
!
interface FastEthernet1/0/2
description "Trunk to NY Router (R2)"
switchport trunk encapsulation dot1q
switchport trunk native vlan 21
switchport trunk allowed vlan 1,20-22
switchport mode trunk
spanning-tree portfast
!
!
interface FastEthernet1/0/13
description 7962 MAC 0021D8B9BC72
switchport trunk encapsulation dot1q
switchport trunk native vlan 21
switchport mode trunk
switchport voice vlan 22
spanning-tree portfast
!
interface FastEthernet1/0/14
description 7942 MAC 0021D8BA2373
switchport trunk encapsulation dot1q
switchport trunk native vlan 21
switchport mode trunk
switchport voice vlan 22
spanning-tree portfast
!
!
interface Vlan20
description MNGMT-NY
ip address 10.1.20.2 255.255.255.0
!
interface Vlan21
description DATA-NY
ip address 10.1.21.2 255.255.255.0
!
interface Vlan22
description VOICE-NY
ip address 10.1.22.2 255.255.255.0
!
!
line con 0
exec-timeout 20 0
logging synchronous
login local
line vty 0 4
exec-timeout 20 0
logging synchronous
login local
length 0
line vty 5 15
no login
!end

No comments: